using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)(at|\@)(.+)";
string input = @"3x10at50%of1RM
3 x 6 at50% of 1RM
3 x 7 at50/60/70kg
3x10 @ 50 / 60 / 90 lbs";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}