import re
regex = re.compile(r"(.+)(at|\@)(.+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("3x10at50%of1RM\n"
"3 x 6 at50% of 1RM\n"
"3 x 7 at50/60/70kg\n"
"3x10 @ 50 / 60 / 90 lbs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")