re = /(.+)(at|\@)(.+)/mi
str = '3x10at50%of1RM
3 x 6 at50% of 1RM
3 x 7 at50/60/70kg
3x10 @ 50 / 60 / 90 lbs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end