import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+)(at|\\@)(.+)";
final String string = "3x10at50%of1RM\n"
+ "3 x 6 at50% of 1RM\n"
+ "3 x 7 at50/60/70kg\n"
+ "3x10 @ 50 / 60 / 90 lbs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}