package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(.+)(at|\@)(.+)`)
var str = `3x10at50%of1RM
3 x 6 at50% of 1RM
3 x 7 at50/60/70kg
3x10 @ 50 / 60 / 90 lbs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}