#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^[ \t]*)Function([^\n\;\/]*);?"
Local $sString = "// Возвращает значения Х и У" & @CRLF & _
"Function UseResolutionMultipler(x# Var,y# Var) ;" & @CRLF & _
" //SetScale ScX,ScY" & @CRLF & _
"End Function ;" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);" & @CRLF & _
"jjj" & @CRLF & _
"" & @CRLF & _
"End Function;"
Local $sSubst = "$1 public static$2\n$1\{"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)