import Foundation
let pattern = #"(^[ \t]*)Function([^\n\;\/]*);?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
// Возвращает значения Х и У
Function UseResolutionMultipler(x# Var,y# Var) ;
//SetScale ScX,ScY
End Function ;
Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);
jjj
End Function;
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 public static$2\n$1\{"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)