import re
regex = re.compile(r"(^[ \t]*)Function([^\n\;\/]*);?", flags=re.MULTILINE)
test_str = ("// Возвращает значения Х и У\n"
"Function UseResolutionMultipler(x# Var,y# Var) ;\n"
" //SetScale ScX,ScY\n"
"End Function ;\n\n\n"
" Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);\n"
"jjj\n\n"
"End Function;")
subst = "$1 public static$2\\n$1\\{"
result = regex.sub(subst, test_str)
if result:
print(result)