using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=:\n\n).*(?=\n)";
string input = @"бла бла
Dear jofjsu7e,
Here is the Steam Guard code you need to login to account jofjsu7e:
R6M43
This email was generated because of a login attempt from a web or mobile device located at ip (CA). The login attempt included your correct account name and password";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}