re = /(?<=:\n\n).*(?=\n)/m
str = 'бла бла
Dear jofjsu7e,
Here is the Steam Guard code you need to login to account jofjsu7e:
R6M43
This email was generated because of a login attempt from a web or mobile device located at ip (CA). The login attempt included your correct account name and password'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end