$re = '/(?<=:\n\n).*(?=\n)/m';
$str = 'бла бла
Dear jofjsu7e,
Here is the Steam Guard code you need to login to account jofjsu7e:
R6M43
This email was generated because of a login attempt from a web or mobile device located at ip (CA). The login attempt included your correct account name and password';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);