import re
regex = re.compile(r"(?<=:\n\n).*(?=\n)", flags=re.MULTILINE)
test_str = ("бла бла\n"
"Dear jofjsu7e,\n\n"
"Here is the Steam Guard code you need to login to account jofjsu7e:\n\n"
"R6M43\n\n"
"This email was generated because of a login attempt from a web or mobile device located at ip (CA). The login attempt included your correct account name and password")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")