import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=:\\n\\n).*(?=\\n)";
final String string = "бла бла\n"
+ "Dear jofjsu7e,\n\n"
+ "Here is the Steam Guard code you need to login to account jofjsu7e:\n\n"
+ "R6M43\n\n"
+ "This email was generated because of a login attempt from a web or mobile device located at ip (CA). The login attempt included your correct account name and password";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}