using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])\1{3,}";
string input = @"a
ab
abc
1
22
22AB
AB
ABC
ABBC
ABBCCDD
EFAEEEEEEE
EEE
EE";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}