use strict;
my $str = 'a
ab
abc
1
22
22AB
AB
ABC
ABBC
ABBCCDD
EFAEEEEEEE
EEE
EE';
my $regex = qr/([a-z])\1{3,}/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}