re = /([a-z])\1{3,}/im
str = 'a
ab
abc
1
22
22AB
AB
ABC
ABBC
ABBCCDD
EFAEEEEEEE
EEE
EE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end