$re = '/:[^%]\D\w*/';
$str = 'SELECT cID, cTIME, DATE_FORMAT(cDATUM,\'%d.%m.%Y %H:%i\') as cDATA FROM tMyTable WHERE cTIME = \'0000-00-00 00:00:00\' and cID > :param1;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);