# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2}).\d{3}Z/$2-$3-$1 $4:$5:$6/gm;t' <<< "2023-05-24T12:34:37.490Z"