use strict;
my $str = '2023-05-24T12:34:37.490Z';
my $regex = qr/(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2}).\d{3}Z/mp;
my $subst = '$2-$3-$1 $4:$5:$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";