re = /(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2}).\d{3}Z/m
str = '2023-05-24T12:34:37.490Z'
subst = '$2-$3-$1 $4:$5:$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result