package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2}).\d{3}Z`)
var str = `2023-05-24T12:34:37.490Z`
var substitution = "$2-$3-$1 $4:$5:$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}