const regex = /(\d{4})-(\d{2})-(\d{2})T(\d{2}):(\d{2}):(\d{2}).\d{3}Z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})-(\\d{2})-(\\d{2})T(\\d{2}):(\\d{2}):(\\d{2}).\\d{3}Z', 'gm')
const str = `2023-05-24T12:34:37.490Z`;
const subst = `$2-$3-$1 $4:$5:$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);