#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<icon>[^\s,]+), *(\w+), *(\w+)"
Local $sString = "🍓, Strawberry, perennial" & @CRLF & _
"🥕, Carrot, biennial ignoring trailing words" & @CRLF & _
"🍆, Eggplant, perennial" & @CRLF & _
"🍅, Tomato, annual" & @CRLF & _
"🥔,Potato,perennial" & @CRLF & _
"# 🍌, Banana, perennial" & @CRLF & _
"invalid, 🍉, format" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")