package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<icon>[^\s,]+), *(\w+), *(\w+)`)
var str = `🍓, Strawberry, perennial
🥕, Carrot, biennial ignoring trailing words
🍆, Eggplant, perennial
🍅, Tomato, annual
🥔,Potato,perennial
# 🍌, Banana, perennial
invalid, 🍉, format
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}