import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<icon>[^\\s,]+), *(\\w+), *(\\w+)";
final String string = "🍓, Strawberry, perennial\n"
+ "🥕, Carrot, biennial ignoring trailing words\n"
+ "🍆, Eggplant, perennial\n"
+ "🍅, Tomato, annual\n"
+ "🥔,Potato,perennial\n"
+ "# 🍌, Banana, perennial\n"
+ "invalid, 🍉, format\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}