const regex = new RegExp('(?P<icon>[^\\s,]+), *(\\w+), *(\\w+)', 'gm')
const str = `🍓, Strawberry, perennial
🥕, Carrot, biennial ignoring trailing words
🍆, Eggplant, perennial
🍅, Tomato, annual
🥔,Potato,perennial
# 🍌, Banana, perennial
invalid, 🍉, format
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}