re = /(?P<icon>[^\s,]+), *(\w+), *(\w+)/m
str = '🍓, Strawberry, perennial
🥕, Carrot, biennial ignoring trailing words
🍆, Eggplant, perennial
🍅, Tomato, annual
🥔,Potato,perennial
# 🍌, Banana, perennial
invalid, 🍉, format
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end