using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BIG\^\K.*?(?=\^00)";
string input = @"^25555555~BIG^20200629^20022222^20200629^55555555^^^DI^00~CUR^ZZ^USD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}