re = /BIG\^\K.*?(?=\^00)/m
str = '^25555555~BIG^20200629^20022222^20200629^55555555^^^DI^00~CUR^ZZ^USD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end