$re = '/BIG\^\K.*?(?=\^00)/m';
$str = '^25555555~BIG^20200629^20022222^20200629^55555555^^^DI^00~CUR^ZZ^USD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);