const regex = /BIG\^\K.*?(?=\^00)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('BIG\\^\\K.*?(?=\\^00)', 'gm')
const str = `^25555555~BIG^20200629^20022222^20200629^55555555^^^DI^00~CUR^ZZ^USD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}