import re
regex = re.compile(r"BIG\^\K.*?(?=\^00)", flags=re.MULTILINE)
test_str = "^25555555~BIG^20200629^20022222^20200629^55555555^^^DI^00~CUR^ZZ^USD"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")