using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>.+) \((?<email>.+)\) will not be able to fill the\s+(?<role>.+)\s+role";
string input = @"Firstname Lastname (email@example.com) will not be able to fill the Role Name role of at the December 31, 2024 meeting.
More example text
...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}