use strict;
my $str = 'Firstname Lastname (email@example.com) will not be able to fill the Role Name role of at the December 31, 2024 meeting.
More example text
...';
my $regex = qr/(?<name>.+) \((?<email>.+)\) will not be able to fill the\s+(?<role>.+)\s+role/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}