package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<name>.+) \((?<email>.+)\) will not be able to fill the\s+(?<role>.+)\s+role`)
var str = `Firstname Lastname (email@example.com) will not be able to fill the Role Name role of at the December 31, 2024 meeting.
More example text
...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}