const regex = /(?<name>.+) \((?<email>.+)\) will not be able to fill the\s+(?<role>.+)\s+role/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>.+) \\((?<email>.+)\\) will not be able to fill the\\s+(?<role>.+)\\s+role', 'g')
const str = `Firstname Lastname (email@example.com) will not be able to fill the Role Name role of at the December 31, 2024 meeting.
More example text
...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}