$re = '/(?<name>.+) \((?<email>.+)\) will not be able to fill the\s+(?<role>.+)\s+role/';
$str = 'Firstname Lastname (email@example.com) will not be able to fill the Role Name role of at the December 31, 2024 meeting.
More example text
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);