using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!(\?)|(\[))(.+(\n|$)))+";
string substitution = @"";
string input = @"this is paragraph line1 line 1
and line 2
?[question_2]{""category"":[]}[who are you]=[] {1,2}
[] OPTION 1
[] OPTION 2
[] OPTION 3
this is paragraph line3
with a line break
?[question_3]{""category"":[]}[picode]=_ [PLACEHOLDER_TEXT]
?[question_1]{""category"":[]}[sex]=() {1}
() male
() femele
this is paragraph line3
in the end of file";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}