const regex = /^((?!(\?)|(\[))(.+(\n|$)))+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!(\\?)|(\\[))(.+(\\n|$)))+', 'gm')
const str = `this is paragraph line1 line 1
and line 2
?[question_2]{"category":[]}[who are you]=[] {1,2}
[] OPTION 1
[] OPTION 2
[] OPTION 3
this is paragraph line3
with a line break
?[question_3]{"category":[]}[picode]=_ [PLACEHOLDER_TEXT]
?[question_1]{"category":[]}[sex]=() {1}
() male
() femele
this is paragraph line3
in the end of file`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);