re = /^((?!(\?)|(\[))(.+(\n|$)))+/m
str = 'this is paragraph line1 line 1
and line 2
?[question_2]{"category":[]}[who are you]=[] {1,2}
[] OPTION 1
[] OPTION 2
[] OPTION 3
this is paragraph line3
with a line break
?[question_3]{"category":[]}[picode]=_ [PLACEHOLDER_TEXT]
?[question_1]{"category":[]}[sex]=() {1}
() male
() femele
this is paragraph line3
in the end of file'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result