import re
regex = re.compile(r"^((?!(\?)|(\[))(.+(\n|$)))+", flags=re.MULTILINE)
test_str = ("this is paragraph line1 line 1\n"
"and line 2\n\n"
"?[question_2]{\"category\":[]}[who are you]=[] {1,2}\n"
"[] OPTION 1\n"
"[] OPTION 2\n"
"[] OPTION 3\n\n"
"this is paragraph line3\n"
"with a line break\n\n"
"?[question_3]{\"category\":[]}[picode]=_ [PLACEHOLDER_TEXT]\n\n"
"?[question_1]{\"category\":[]}[sex]=() {1}\n"
"() male \n"
"() femele \n\n\n"
"this is paragraph line3\n"
"in the end of file")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)