#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\([1-9]\d\)\s9?\d{4}-\d{4}"
Local $sString = "(11) 1111-1111 - fixo válido" & @CRLF & _
"(11) 11111-1111 - celular inválido" & @CRLF & _
"(11) 91111-1111 - celular válido" & @CRLF & _
"(11) 01111-1111 - celular inválido" & @CRLF & _
"(01) 91111-1111 - celular válido" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")