import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([1-9]\\d\\)\\s9?\\d{4}-\\d{4}";
final String string = "(11) 1111-1111 - fixo válido\n"
+ "(11) 11111-1111 - celular inválido\n"
+ "(11) 91111-1111 - celular válido\n"
+ "(11) 01111-1111 - celular inválido\n"
+ "(01) 91111-1111 - celular válido\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}