re = /\([1-9]\d\)\s9?\d{4}-\d{4}/
str = '(11) 1111-1111 - fixo válido
(11) 11111-1111 - celular inválido
(11) 91111-1111 - celular válido
(11) 01111-1111 - celular inválido
(01) 91111-1111 - celular válido
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end