import Foundation
let pattern = #"\([1-9]\d\)\s9?\d{4}-\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(11) 1111-1111 - fixo válido
(11) 11111-1111 - celular inválido
(11) 91111-1111 - celular válido
(11) 01111-1111 - celular inválido
(01) 91111-1111 - celular válido
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)