using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([1-9]\d\)\s9?\d{4}-\d{4}";
string input = @"(11) 1111-1111 - fixo válido
(11) 11111-1111 - celular inválido
(11) 91111-1111 - celular válido
(11) 01111-1111 - celular inválido
(01) 91111-1111 - celular válido
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}