#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(ab|cd)e(fg|hi)"
Local $sString = "abcdefghi"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)