const regex = /(ab|cd)e(fg|hi)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ab|cd)e(fg|hi)', 'g')
const str = `abcdefghi`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);