#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^)(?<!\t)\t+"
Local $sString = " BBHH Balanço Patrimonial" & @CRLF & _
" 1. ATIVO Assets" & @CRLF & _
" 1.1 CIRCULANTE" & @CRLF & _
" 1.2 NÃO CIRCULANTE" & @CRLF & _
" 2. PASSIVO Liabilities and Equity" & @CRLF & _
" 3. RECEITAS" & @CRLF & _
" 4. CUSTOS E DESPESAS" & @CRLF & _
" 4.1 CUSTOS DE PRODUTOS VENDIDOS E SERVIÇOS" & @CRLF & _
" 4.1.1 CUSTOS DE PRODUTOS VENDIDOS" & @CRLF & _
" 4.1.1.1 CUSTOS DE PRODUTOS VENDIDOS" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")