re = /(?<!^)(?<!\t)\t+/m
str = ' BBHH Balanço Patrimonial
1. ATIVO Assets
1.1 CIRCULANTE
1.2 NÃO CIRCULANTE
2. PASSIVO Liabilities and Equity
3. RECEITAS
4. CUSTOS E DESPESAS
4.1 CUSTOS DE PRODUTOS VENDIDOS E SERVIÇOS
4.1.1 CUSTOS DE PRODUTOS VENDIDOS
4.1.1.1 CUSTOS DE PRODUTOS VENDIDOS
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end